Is everything ok with "allyAttacking" filter?

Botique
Algorithm
Algorithm
Posts: 96

Is everything ok with "allyAttacking" filter?

Post#1 » 26 Feb 2017, 20:52

Replay 362484

At the moment of 4:44 my MG is shooting at the retreating shotgun.
You will notice that at 4:45 immediately when shotgun is out of range, MG swaps to the assault.

What is strange that both are shooting "Attack closest medium/long range allyAttacking enemy".
And I mean it swithces from shotgun to assault in like one moment, without traversing the tree from left to right - it's like it never lost the target!
Shouldn't there be one tick of "self not attacking". Coz I have another node which relies on the bot NOT attacking. But the node was calculated as "false" liek my MG was attacking all along without loosing the target.

Is it as it should be?

harthag
Automaton
Automaton
Posts: 197

Re: Is everything ok with "allyAttacking" filter?

Post#2 » 26 Feb 2017, 23:23

I can't see which bot is being targeted, but i do see the "prep to fire" circle get to about 3/4 full and then reset itself, which seems to match the new tick and changing targets...

Botique
Algorithm
Algorithm
Posts: 96

Re: Is everything ok with "allyAttacking" filter?

Post#3 » 28 Feb 2017, 22:05

Yes but there was no "not attacking" phase in between

harthag
Automaton
Automaton
Posts: 197

Re: Is everything ok with "allyAttacking" filter?

Post#4 » 28 Feb 2017, 23:16

Botique wrote:Yes but there was no "not attacking" phase in between

I don't think there should be any "not attacking" phase. The bot changed the target of its attack, so it had to start the "prep to fire" process, but it continued to attack, so it was never "not attacking" in between. At least as far as I can tell from your info.

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest