Possible memory leak in AI editor

User avatar
HBomb
Algorithm
Algorithm
Posts: 93

Possible memory leak in AI editor

Post#1 » 23 Dec 2016, 21:46

Platform: Android (HTC 10)
Version: 6.1.2 (problem noticable since 6)

Having gone mad remodelling my AI to use tags and spent two hours in the AI Editor, I noticed everything grinding to a halt. Just like when I had a single subroutine with 150 nodes in, except it persists through small and large subs alike. Restarting sorts this issue and the slowness only appears in huge subs, as expected. But given time in the editor moving/creating/deleting things it does slow to a halt until restarted again.

I don't know if this is rubbish garbage collection on Unity's part or lack of unloading old data kn my phone's part, but I just wanted to make sure this wasn't a game issue.

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Possible memory leak in AI editor

Post#2 » 24 Dec 2016, 00:14

I checked briefly and didn't see anything obvious.
The game slowing down is not necessary a memory leak problem. Did you monitor your RAM to come to this conclusion?
Also, did it happen with a previous version of the game?

User avatar
HBomb
Algorithm
Algorithm
Posts: 93

Re: Possible memory leak in AI editor

Post#3 » 24 Dec 2016, 01:08

I will monitor it over the next session and get back to you, but I can only see to the nearest 100mb. I guess memory leak is my go-to problem if a game slows down over time in a particular area. Can't say I'd know what else it would be.

I don't know if it was present before version 6 because I just played with my single raging huge AI which would cause lag all by itself regardless.

EDIT:
Nope, hardly a rise in ram usage. And Boost+ "reclaimed" 52 mb of RAM mid game and slowdown was still occouring

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest