weirdest bug ever

M4L4
Script
Script
Posts: 49

weirdest bug ever

Post#1 » 30 Nov 2018, 11:18

so, i'm playing te match #1513213, at 1:55 score is 2-2, there's 1 res left on the ground, both teams go for it, my sg acts stupid (my fault) and dies, i immediately click "shift time" to check what happened (without waiting for the match to end), and...

after completing the shift time, i get the blue message "updating results You Won", my bots are now all alive (obviously), but positions are different (as they never moved toward the last resource), there are no more resources on the ground, and the score is now 3-2 in my advantage. before clicking shift time none of the bots (allies or enemies) had even touched the last res, so there's no way someone scored it.
I went back to the match list, and the game is listed as blue with +11 score.
If i replay it, everything happen as it did first time, we get to 2-2, move to the last res, my sg dies, then the others die, enemy score last point and i loose the match. I also got the red "updating results you loose" popup, but the match is still listed as won as far as i can see.

can someone else watch the replay just to be sure that we all see same stuff?

User avatar
Hairy Phil
Automaton
Automaton
Posts: 147
Contact:

Re: weirdest bug ever

Post#2 » 30 Nov 2018, 20:53

I just viewed match 1513213 and it's as you described. Your shotgun is killed at 1:55 remaining, then the opponent kills your other 3 bots and scores the final resource for a 3-2 win.

User avatar
Hairy Phil
Automaton
Automaton
Posts: 147
Contact:

Re: weirdest bug ever

Post#3 » 30 Nov 2018, 20:57

Wow, okay, just for fun I also clicked 10-second-rewind (going from 1:51 to 2:01), and it also declared a victory for you! Definitely a bug! (Steam version of game.)

M4L4
Script
Script
Posts: 49

Re: weirdest bug ever

Post#4 » 01 Dec 2018, 02:49

lol now that you've mentioned it i've tried it again, somehow if you click rewind right after my sg dies in the replay (1:55), it get teleported on the nearest ally base, resource disappear, and i get the winning point, you can clearly see the different position of my bots at standard 2:05 and at 2:05 after the rewind.

rechecked:
it also works if you rewind way before my sg dies , click rewind at 2:25, i still immediately win.

(android version)

User avatar
GFX47
Dev
Posts: 2865

Re: weirdest bug ever

Post#5 » 04 Dec 2018, 19:33

I managed to reproduce it. I'm working on a fix.

M4L4
Script
Script
Posts: 49

Re: weirdest bug ever

Post#6 » 04 Dec 2018, 21:07

GFX47 wrote:I managed to reproduce it. I'm working on a fix.


do i get a badge for the first quantum gladiabot match? "you loose, but meh.. you also win" :D

User avatar
GFX47
Dev
Posts: 2865

Re: weirdest bug ever

Post#7 » 05 Dec 2018, 11:41


User avatar
GFX47
Dev
Posts: 2865

Re: weirdest bug ever

Post#8 » 05 Dec 2018, 16:45

Fixed in Beta 3.2 currently on the RC branch on Steam.
Could you please confirm?

M4L4
Script
Script
Posts: 49

Re: weirdest bug ever

Post#9 » 05 Dec 2018, 17:56

sorry but i'm playing from android.
anyway, how can i check it after patch? will it fix the replay retroactively?

User avatar
GFX47
Dev
Posts: 2865

Re: weirdest bug ever

Post#10 » 05 Dec 2018, 18:02

The Android build should be available on the RC branch in a few minutes.
Unfortunately, the resolution engine code changed so you won't be able to replay this match. But please tell me if you manage to reproduce the bug on another one.

M4L4
Script
Script
Posts: 49

Re: weirdest bug ever

Post#11 » 05 Dec 2018, 22:53

ok, i've haven't tried to reproduce the bug after reporting it (beside toying with the bugged replay), and never saw something like that again.
If it happens again i'll report it asap

User avatar
Revenge
Neural Network
Neural Network
Posts: 398
Contact:

Re: weirdest bug ever

Post#12 » 09 Dec 2018, 17:02

M4L4 wrote:
GFX47 wrote:I managed to reproduce it. I'm working on a fix.


do i get a badge for the first quantum gladiabot match? "you loose, but meh.. you also win" :D

*awards you with virtual quantum badge* :shock:

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests