Just lost all my AI.

Addictorator
Script
Script
Posts: 12

Just lost all my AI.

Post#1 » 17 Dec 2016, 21:34

When I opened the game, it said something about a data conflict with the local data not matching server data and about which to keep. I thought there was something outdated with the local data, so I unthinkingly selected server data. Now, all my AI are gone. Each and every single one of them, that I've spent hours on. And no backups, because there was no such AI backup export option and I didn't think to take screenshots or something. Will uninstalling and reinstalling help or is any data retrieval possible, because I just can't build all of those painstakingly worked AI from scratch. Been here since itch.io days, but this is honestly frustrating. Help would be much appreciated.

HDeffo
Neural Network
Neural Network
Posts: 212

Re: Just lost all my AI.

Post#2 » 17 Dec 2016, 21:49

Don't worry too much about it honestly. Being an alpha game I'm sure 2-3 weeks your AI would've been outdated enough to require you to start from scratch again

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#3 » 17 Dec 2016, 21:53

What is your player name?

pier4r
Skynet
Skynet
Posts: 3389

Re: Just lost all my AI.

Post#4 » 17 Dec 2016, 22:00

Wait until alpha 6, you would have to rework your AI nevertheless, so nothing so bad.

It happened to me too, what I discovered: if I'm in the AI editor, I always choose local date. If i edited the AI the last time minutes ago, I always choose server data (assuming that I was always connected to the internet).
http://www.reddit.com/r/Gladiabots/wiki/players/pier4r_nvidia_shield_k1 -> Gladiabots CHAT, stats, insights and more ;

User avatar
NullPointer
Autonomous Entity
Autonomous Entity
Posts: 539

Re: Just lost all my AI.

Post#5 » 17 Dec 2016, 22:06

The AIs in Alpha 6 don't have to be reworked, the subtrees are helpful but they don't change the battle itself in any way.

I never select "Server Data", although sometimes I almost do because the message pops up suddenly. Maybe the buttons could be hidden for 2 seconds so we can read the message first.

It's a tricky question anyway, we don't know the internals of the cloud sync to understand what is the consequence of selecting one option or another.

At the moment we can only have 1 device associated with an account, the code could assume the local data is always right and then fix this issue (why was there a conflict in the first place?) when multiple devices are supported.

Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#6 » 17 Dec 2016, 23:31

GFX47 wrote:What is your player name?


My player name is "Guy".

Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#7 » 17 Dec 2016, 23:38

HDeffo wrote:Don't worry too much about it honestly. Being an alpha game I'm sure 2-3 weeks your AI would've been outdated enough to require you to start from scratch again

pier4r wrote:Wait until alpha 6, you would have to rework your AI nevertheless, so nothing so bad.


Still hours of work gone - I wouldn't call it "nothing so bad", no offense. And they could be used as inspiration even after everything gets reworked. Kind of making light of the situation here. And I've had success without majorly reworking my first complete AI, which took me the first half of October. So yeah, it was pretty good. Came back after a half month hiatus. New bots. Alpha 5. Same AI still worked wonders.

Of course, bugs happen, and I really appreciate that GFX47 is doing the best he can to help :D

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#8 » 17 Dec 2016, 23:55

You said all your AIs are gone, is that really all your AIs or "just" the latest ones?

Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#9 » 18 Dec 2016, 00:06

GFX47 wrote:You said all your AIs are gone, is that really all your AIs or "just" the latest ones?


All of them. I checked the AI list, and it was empty. I had 6-7 or so AI as far as I can remember, most of them named after Greek mythological figures based on their function and style. I later went to a mission just to make sure it wasn't a bug with just the AI editor not showing the AI, and it seems to have auto-generated the default Attacker AI (since my list was empty I guess). Nothing else but the game tutorial Attacker AI on my AI list at the moment.

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#10 » 18 Dec 2016, 00:12

Are you playing on Alpha 5.3.1 or 6?

Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#11 » 18 Dec 2016, 00:18

GFX47 wrote:Are you playing on Alpha 5.3.1 or 6?

Alpha 5.3.1. Is Alpha 6 out? :shock:
On android phone btw. No other devices.

Edit: Yes subtrees finally omg. TIme to start bulking again! Or does alpha 6 come with "more executed nodes = slower bot response time" trello thing? Been streamlining AI in preparation for that :lol:

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#12 » 18 Dec 2016, 00:25

Could you please launch the game and send me your logs?

Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#13 » 18 Dec 2016, 00:31

GFX47 wrote:Could you please launch the game and send me your logs?

Um. I launched? What should I send, and how? You mean my multiplayer logs?
Last edited by Addictorator on 18 Dec 2016, 00:31, edited 1 time in total.

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#14 » 18 Dec 2016, 00:31


Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#15 » 18 Dec 2016, 00:34


Done. And sorry, didn't read that earlier :?

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#16 » 18 Dec 2016, 00:41

OK. Now please make a small modification on one of your AIs (like just moving a node), wait for a minute and send me the new logs.

Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#17 » 18 Dec 2016, 00:48

Done.
Edit: Didn't wait for a minute. Sent again.

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#18 » 18 Dec 2016, 00:54

Got it.
I'm sorry, that's really weird, it's like it was the first time you were connected after modifying an AI.
The first cloud save of your AIs occurred 5 minutes ago.

Addictorator
Script
Script
Posts: 12

Re: Just lost all my AI.

Post#19 » 18 Dec 2016, 00:59

GFX47 wrote:Got it.
I'm sorry, that's really weird, it's like it was the first time you were connected after modifying an AI.
The first cloud save of your AIs occurred 5 minutes ago.


So the previous AI isn't on cloud, like a backup or anything? Is it available locally on my phone? There's no way to retrieve it? D:

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Just lost all my AI.

Post#20 » 18 Dec 2016, 01:02

I'm very sorry but it's really lost.

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest