Importing AI doesn't connect all modules

MrChris
Automaton
Automaton
Posts: 170

Importing AI doesn't connect all modules

Post#1 » 15 Oct 2018, 14:48

I have imported 2 match AIs and a few different modules weren't set properly. It just showed the question mark as the module name rather than the proper name. I had to re-select the modules before they would work.


In this screenshot, none of the visible modules names were present (I have since re-selected the correct module) . This is a screenshot of the "//new/secureToBase" module:

Screenshot from 2018-10-15 13-45-56.png
Screenshot from 2018-10-15 13-45-56.png (151.8 KiB) Viewed 190 times


If you import my AI from match #1363562 then you will see this happen.

It also happened in a lot of other places in my AI. It's taken me a while to find them all and fix them.
Last edited by MrChris on 15 Oct 2018, 15:25, edited 3 times in total.
------------------------------------------------
My in-game name is MrChris

Creator of the unofficial Gladiabots stats page: https://gladiabots-stats.info.tm/mrchris
And the Gladiabots retreatment simulator: https://cmrichards.github.io/glad_simulation

User avatar
Hairy Phil
Automaton
Automaton
Posts: 140
Contact:

Re: Importing AI doesn't connect all modules

Post#2 » 15 Oct 2018, 15:19

Was the missing link always between Sub-AIs and Connectors? Or other types of node too?

MrChris
Automaton
Automaton
Posts: 170

Re: Importing AI doesn't connect all modules

Post#3 » 15 Oct 2018, 15:21

Ok I think I didn't explain this properly - i've fixed the original post.

There were no missing links. The modules themselves weren't selected. They were empty modules with just a question mark "?" in them rather than the module name.
------------------------------------------------
My in-game name is MrChris

Creator of the unofficial Gladiabots stats page: https://gladiabots-stats.info.tm/mrchris
And the Gladiabots retreatment simulator: https://cmrichards.github.io/glad_simulation

User avatar
GFX47
Dev
Posts: 2845

Re: Importing AI doesn't connect all modules

Post#4 » 16 Oct 2018, 08:56

Were all the sub AIs present in the imported folder though?

MrChris
Automaton
Automaton
Posts: 170

Re: Importing AI doesn't connect all modules

Post#5 » 16 Oct 2018, 14:13

Yes
------------------------------------------------
My in-game name is MrChris

Creator of the unofficial Gladiabots stats page: https://gladiabots-stats.info.tm/mrchris
And the Gladiabots retreatment simulator: https://cmrichards.github.io/glad_simulation

User avatar
GFX47
Dev
Posts: 2845

Re: Importing AI doesn't connect all modules

Post#6 » 17 Oct 2018, 13:58

Could you retry and send me your logs?

MrChris
Automaton
Automaton
Posts: 170

Re: Importing AI doesn't connect all modules

Post#7 » 17 Oct 2018, 22:41

When I click on the bug icon and click 'ok' it opens up my code editor which then freezes. So I can't access the log file data.
------------------------------------------------
My in-game name is MrChris

Creator of the unofficial Gladiabots stats page: https://gladiabots-stats.info.tm/mrchris
And the Gladiabots retreatment simulator: https://cmrichards.github.io/glad_simulation

User avatar
GFX47
Dev
Posts: 2845

Re: Importing AI doesn't connect all modules

Post#8 » 18 Oct 2018, 09:29

You must have your OS set to open html files with the wrong editor.
Anyway it should be fixed in 2.3. The RC is on the "release-candidate" branch on Steam, test branch on Android.

MrChris
Automaton
Automaton
Posts: 170

Re: Importing AI doesn't connect all modules

Post#9 » 18 Oct 2018, 21:42

2.3 doesn't seem to be active on Linux
------------------------------------------------
My in-game name is MrChris

Creator of the unofficial Gladiabots stats page: https://gladiabots-stats.info.tm/mrchris
And the Gladiabots retreatment simulator: https://cmrichards.github.io/glad_simulation

User avatar
GFX47
Dev
Posts: 2845

Re: Importing AI doesn't connect all modules

Post#10 » 18 Oct 2018, 22:15

On the release candidate branch?

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest