Shotgun bug

LethalLuck
Hello World
Hello World
Posts: 4

Shotgun bug

Post#1 » 25 Sep 2018, 17:40

Shotgun seems to attack even when no nodes are telling it to.

https://youtu.be/Ollx8JkKwZU
Attachments
Screenshot_20180925-104052.png
Shotgun AI
Screenshot_20180925-104052.png (470.29 KiB) Viewed 224 times
Screenshot_20180925-105030.png
Retreat AI
Screenshot_20180925-105030.png (572.68 KiB) Viewed 224 times

User avatar
GFX47
Dev
Dev
Posts: 2873

Re: Shotgun bug

Post#2 » 25 Sep 2018, 17:47

Please use the AI debugger during combat.

User avatar
Hairy Phil
Automaton
Automaton
Posts: 147
Contact:

Re: Shotgun bug

Post#3 » 25 Sep 2018, 21:18

Edit: Nevermind. I didn't see the YouTube link, only the screenshot. Simple answer: The shotgun doesn't attack in the video.

I don't see any connected attack nodes there, so my guess is that it's simply because you're looking at the wrong team. In matches against other players, your team can start at either the bottom of the arena, same as in single player, but also at the top. Check the colour of the bots. Alternatively, you may not have assigned this AI to your Shotgun bot for multiplayer, so it's using your Assault AI by default.
Last edited by Hairy Phil on 25 Sep 2018, 21:35, edited 1 time in total.

User avatar
DjSapsan
Script
Script
Posts: 48

Re: Shotgun bug

Post#4 » 25 Sep 2018, 21:26

I dont see where is he attacking. Only collecting resources...

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest