Some filters about ranges are not shown in ascending (or descending) order.

pier4r
Skynet
Skynet
Posts: 3381

Some filters about ranges are not shown in ascending (or descending) order.

Post#1 » 23 Sep 2018, 20:38

For example:

shield: 0 or 25 or 50 or 75.
The filter shows: 0, 75, 25, 50 . That's a bit less readable.
http://www.reddit.com/r/Gladiabots/wiki/players/pier4r_nvidia_shield_k1 -> Gladiabots CHAT, stats, insights and more ;

User avatar
DjSapsan
Script
Script
Posts: 48

Re: Some filters about ranges are not shown in ascending (or descending) order.

Post#2 » 23 Sep 2018, 23:42

Just switch off and on any filter in node

User avatar
GFX47
Dev
Dev
Posts: 2896

Re: Some filters about ranges are not shown in ascending (or descending) order.

Post#3 » 24 Sep 2018, 08:56

It's just visual, doesn't impact execution.

pier4r
Skynet
Skynet
Posts: 3381

Re: Some filters about ranges are not shown in ascending (or descending) order.

Post#4 » 24 Sep 2018, 19:19

I know it is visual, I wondered if it is wanted. If yes, if it could be fixed.
http://www.reddit.com/r/Gladiabots/wiki/players/pier4r_nvidia_shield_k1 -> Gladiabots CHAT, stats, insights and more ;

User avatar
Hairy Phil
Automaton
Automaton
Posts: 149
Contact:

Re: Some filters about ranges are not shown in ascending (or descending) order.

Post#5 » 10 Oct 2018, 19:17

This is annoying me now. I don't mind so much whether say range or shield comes first, but I do mind when icons of the same type appear out of sequence. There are hundreds for me to manually fix. I think there just needs to be a one-time "reorder" function run on every node each time a new version of the AI editor is released (as opposed to say every time you open the AI).
Attachments
icons in wrong order.png
icons in wrong order.png (25.99 KiB) Viewed 376 times

User avatar
GFX47
Dev
Dev
Posts: 2896

Re: Some filters about ranges are not shown in ascending (or descending) order.

Post#6 » 10 Oct 2018, 19:23

It's fixed in Beta 2.2 (RC testable here: viewtopic.php?f=4&t=1667).

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests