Unable to complete match if all enemies killed

botmanbot
Hello World
Hello World
Posts: 3

Unable to complete match if all enemies killed

Post#1 » 06 Sep 2018, 20:03

Before I report a bug I want to know if this is intended behavior?

What happens:

Match goes as expected until last enemy dies. Then all my bots freeze.

What I expect:

My bots continue to attempt to catch/score resources.

Only happens in online vs other players modes. Offline 'Campaign' mode works as I expect (bots continue to run after all enemies killed)
Last edited by botmanbot on 06 Sep 2018, 20:10, edited 1 time in total.

User avatar
Hairy Phil
Automaton
Automaton
Posts: 153
Contact:

Re: Unable to complete match if all enemies killed

Post#2 » 06 Sep 2018, 20:09

It'll be because all your capture nodes include "at range X from enemy" and since there are no enemies, they all evaluate to false. Just add one without a range condition.

botmanbot
Hello World
Hello World
Posts: 3

Re: Unable to complete match if all enemies killed

Post#3 » 06 Sep 2018, 20:12

Using the same AIs in Campaign mode it works fine. Sounds like it is a legit bug. I'll report. thx :)

botmanbot
Hello World
Hello World
Posts: 3

Re: Unable to complete match if all enemies killed

Post#4 » 06 Sep 2018, 20:58

Darn it! You were totally right Hairy Phil!

Turns out I was testing my bots on harder campaign opponents where I didn't kill them all. I could have _sworn_ I killed them all....but going back to an easy campaign mission where I _do_ kill all enemies I get the exact same issue, and it is a bug in my 'code'.

Lesson learned: when you think you found a bug in the compiler....odds are you're just not seeing the bug in your own code.

Thanks Hairy Phil for helping me see the light :)

User avatar
GFX47
Dev
Dev
Posts: 2914

Re: Unable to complete match if all enemies killed

Post#5 » 07 Sep 2018, 09:38

botmanbot wrote:Lesson learned: when you think you found a bug in the compiler....odds are you're just not seeing the bug in your own code.


Image

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 9 guests