Tag applied even though node isn't executed

sollniss
Automaton
Automaton
Posts: 178

Tag applied even though node isn't executed

Post#1 » 05 Mar 2018, 16:21

https://i.imgur.com/CWFdSjz.mp4

AB is applied even though only A is executed.
Attachments
Unbenanntdcvvcx.PNG
Unbenanntdcvvcx.PNG (144.51 KiB) Viewed 338 times

User avatar
GFX47
Dev
Posts: 2861

Re: Tag applied even though node isn't executed

Post#2 » 06 Mar 2018, 09:49

My guess: all your bots use the same AI.
On the team tag tick:
- bot #1 tagged A
- bot #2 saw tag A and tagged B
- all the other bots saw tag A and B, only tagged A

sollniss
Automaton
Automaton
Posts: 178

Re: Tag applied even though node isn't executed

Post#3 » 06 Mar 2018, 14:31

Hm. Is this intended?

I've also noticed that when I restart the game, sometimes B gets tagged one tick after. That means the execution is not unique.

mcompany
Autonomous Entity
Autonomous Entity
Posts: 872

Re: Tag applied even though node isn't executed

Post#4 » 07 Mar 2018, 04:37

GFX47 wrote:My guess: all your bots use the same AI.
On the team tag tick:
- bot #1 tagged A
- bot #2 saw tag A and tagged B
- all the other bots saw tag A and B, only tagged A

Hmm... Idk, I've seen odd situations where even with bot tags I could tag everything on the first tick despite it failing after the first tag it tried to make, so I feel like that may not be the full explaintion

User avatar
GFX47
Dev
Posts: 2861

Re: Tag applied even though node isn't executed

Post#5 » 07 Mar 2018, 07:34

Remember that AIs execution are sequential, even if they happen at the same tick.
So if you have the same tagging procedure on several bots, you have to find which one gets executed first to debug it.

mcompany
Autonomous Entity
Autonomous Entity
Posts: 872

Re: Tag applied even though node isn't executed

Post#6 » 07 Mar 2018, 08:49

GFX47 wrote:Remember that AIs execution are sequential, even if they happen at the same tick.
So if you have the same tagging procedure on several bots, you have to find which one gets executed first to debug it.

In my case, I'm using bot tags, so the execution order doesn't matter. Anyways, here's a screenshot
Screenshot_20180224-151944.png
Screenshot_20180224-151944.png (1.01 MiB) Viewed 290 times

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest