Search found 1 match

by Macpo
19 Mar 2019, 16:08
Forum: General Discussions
Topic: "this version of the game is not supported anymore"
Replies: 1
Views: 252

"this version of the game is not supported anymore"

Hi, Am I stupid ? Here is what my gladiabot software says when i try to start a new game : ""this version of the game is not supported anymore Please update the game to the latest version" Fair enough, I try to find how to update the game, but I cant. Finally I find a way to check upd...

Go to advanced search